Back to overview
Downtime

Admin Content Creation Error

Apr 28, 2026 at 9:44pm UTC

Resolved
Apr 28, 2026 at 11:50pm UTC

Video Uploads when editing content in admin is Resolved.

Created
Apr 28, 2026 at 9:44pm UTC

We're currently experiencing an issue when attempting to upload media for content items in Apollos Admin. We are actively working on the issue now.